TimeServer ratings

Provides TIME (RFC868), DAYTIME (RFC867) and SNTP (RFC1769) protocols on Windows
rating
G
Guest
8 years ago
Write a comment

Alternative downloads

Absolute Time Server
rating

It is a full-fledged time server capable of running as a Windows service.

Advanced Time Synchronizer
rating

Synchronizes your PC clock with public time servers on the Internet.

Atomic Time Synchronizer
rating

Synchronizes computer time with NIST atomic time servers.